-----Original Message-----
SHOW CONTRIBUTOR LIST ....

I posted this information and the February stats to this list.

Lo and behold, I went (or TRIED to go) to that location today to get  the stats for March and the button is gone. Is this a decision of the  list management (which is who, exactly?) or simply a strange and  complicating coincidence?

---------------------------

I just checked the mailing list, going to the archives, and found the button there and working. A couple of things may be going on ...

(1) The link has moved relative to the page. Try going back to the lists archive page and navigating down. 

http://list.uvm.edu/archives/science-for-the-people.html

(note that the URL get's mangled by the names of the scripts that are generating these pages, so bookmarks are probably broken in the recent upgrade).

(2) The page may be password protected. Try logging out and logging in again to recache your access to this page.  (Several listserv functions are password protection with the (misplaced?) hope of cutting down on spam farmers. 

(3) The next recommended step, alas, testing the process on a different browser or computer. Malware, etc, often affects browsers in unexpected ways ... so I never trust a result from a single browser or even computer. If it works in a different browser, I'd suggest backing up your documents, and then installing one of the adware, malware, etc packages and seeing if you can get your computer into a safer configurqation. (Myself, I have to reinstall windows about once a year, just from routine use ... and that's with antivirus, antimalware, anti-xyz software installed. )

Steve