Print

Print


The first two lines of the "real" magicscript are

error_reporting( E_ALL );
ini_set( 'display_errors', 'off' );

However, it appears that no combination of those in your own scripts  
gets things turned on again.

However, if the failed URL is, say,

	http://www.uvm.edu/our_stuff/?Page=failed.php

then

	http://www.uvm.edu/our_stuff/failed.php

certainly will show your errors

On Nov 13, 2009, at 11:55 AM, Tyler Whitney wrote:

> Hi Folks,
>
> I still seem to be having issues with error reporting working. I get  
> no errors at all when my scripts don't work, I should also note that  
> I AM using the UVM Template, so I am curious as to whether or not  
> the include in the magicscript.php changes the error reporting level?
>
> It is rather frustrating, but either way, error_reporting(E_ALL)  
> among other solutions that I have tried do not seem to be working. I  
> know there is a syntax error or such somewhere when I see the blank  
> template and notice that the footer bar is missing, meaning not all  
> scripts ran correctly, and then begins the search of syntax with no  
> guidance.
>
> I've even used a site that lets you copy and paste your PHP code to  
> find my errors, and that usually points them out right away.
>
> Any light on this? Perhaps the magicscript has error_reporting off?
>
> Tyler
>
> On Tue, Nov 10, 2009 at 9:31 AM, Jim Lawson <[log in to unmask]> wrote:
> Hi Tyler,
>
> The default for error_reporting on www.uvm.edu is "E_ALL & ~E_NOTICE",
> or "report all errors except notices".
>
> display_errors is on.
>
> It's possible that some other script that you are including changes  
> the
> error_reporting level.  But, in any event, you should be able to call
> error_reporting(E_ALL) as you like.
>
> Jim
>
> Tyler Whitney wrote:
> > Hello All:
> >
> > Just curious, not sure if I missed a previous discussion about  
> this, is
> > error reporting turned off in PHP5? If so, is this on purpose? If  
> so, I
> > should be able to use the function error_reporting( ); in my  
> scripting
> > to turn it on per page to help with debugging am I right? I guess I
> > could simply test it... but my code is so good I have nothing to  
> test it
> > with (haha, more like I spent ages trying to find a missing $) ...  
> thanks.
> >
> > Tyler
> >
>
>
> --
> Jim Lawson
> Systems Architecture & Administration
> Enterprise Technology Services
> University of Vermont
> Burlington, VT USA
>
>
>

-----------------------------------------------------------------------
| Wesley Alan Wright <mailto:[log in to unmask]>                   |
| Academic Computing Services       __0__                             |
| Room 407 Lafayette Building      / \ | \                            |
| University of Vermont              \77                              |
| Burlington, Vermont 05405-0160 USA. \\  http://www.uvm.edu/skivt-l  |
| Voice:802-656-1254 FAX:802-???-????  vv                             |
| aim:goim?screenname=maddogskideath      http://www.uvm.edu/~waw/    |