I had some Gateways that kept giving me a similar issue and sometimes pulling the memory completely out and re-seating it fixed it.  If not, I had to reset the NVRAM.  If I remember correctly I did something along these lines:

Opened case and located a BLUE jumper in the lower corner across from the middle PCI slot.  Moved it from position 1 and 2 to positions 2 and 3. 

Restarted the machine. 

Went to Bios: Boot Config: Advanced  and chose to reset configuration data. 

Clicked Yes, F10 to exit and save.

Moved jumper back.

On Mon, Apr 19, 2010 at 1:01 PM, School Information Technology Discussion <[log in to unmask]> wrote:
I have to support 11 Gateway Pentium D computers in my video lab, running XP Pro with 2 GB of RAM.  Suddenly, 2 of the machines will not boot.  Really  won't boot, as in the DVD drive light briefly flashes at startup, but the hard drive never spins up.  I don't even get the boot menu/bios screen.  I've tried the basics, nothing seems to work.  I'm not a newbie, but this mystifies me.  I wondered if was the CMOS battery; I pulled the battery and  reset it, which allowed the computer to restart in safe mode, but at reboot it went back to a blank screen.  Hardware isn't my specialty, but the fact I can't even access the bios says I need some advice.  Help?  

Drew Blanchard
Technology Teacher
Winooski City Schools
Normand St.
Winooski, VT 05404
(802) 655 - 3530 x6073

Lisa Brande
Tech Support Specialist
Bristol Elementary School
802-453-3227 x268