Rama:

Is it the installer that is generating the error, or is the product getting installed and then not starting up?

I found a reference to a "The VPN client driver has encountered an error" on this page:
http://www.cisco.com/en/US/products/ps6120/products_tech_note09186a00809b4754.shtml

There are some recommendations here.  The first being that you should disable the "Routing and Remote Access" service before installing AnyConnect.  There are further remediations recommended if that does not work.

It also is recommended to analyze the setup logs for more detailed error information.  I have pasted in the log file locations below...

J. Greg Mackinnon | Systems Administrator
ETS Systems Architecture and Administration | University of Vermont
Phone: 802-656-8251 | Web: http://www.uvm.edu/~jgm


Complete these steps:
  1. Obtain the device log file:

    • Windows XP / Windows 2000:

      \Windows\setupapi.log
      
    • Windows Vista:

      Note: Hidden folders must be made visible in order to see these files.

      \Windows\Inf\setupapi.app.log 
          \Windows\Inf\setupapi.dev.log
      

    If you see errors in the setupapi log file, you can turn up verbosity to 0x2000FFFF as described in this Windows KB articleleavingcisco.com[log in to unmask]" width="18" height="18">. Note the article says to set it to 0xFFFF, but if you add the high order value of 0x2, it makes the logging faster.

  2. Obtain the MSI installer log file:

    If this is an initial web deploy install, this log is located in the per-user temp directory.

    • Windows XP / Windows 2000:

      \Documents and Settings\<username>\Local Settings\Temp\
      
    • Windows Vista:

      \Users\<username>\AppData\Local\Temp\
      

    If this is an automatic upgrade, this log is in the temp directory of the system:

    \Windows\Temp
    

    The filename is in this format: anyconnect-win-x.x.xxxx-k9-install-yyyyyyyyyyyyyy.log. Obtain the most recent file for the version of the client you want to install. The x.xxxx changes based on the version, such as 2.0.0343, and yyyyyyyyyyyyyy is the date and time of the install.





On 9/28/2010 7:12 AM, Andrew Hendrickson wrote:
[log in to unmask]" type="cite">
Have you tried the 2.5.1025 standalone application found at http://www.uvm.edu/software


On Sep 27, 2010, at 9:34 PM, Rama Kocherlakota wrote:

No, I thought it might be something like that at first when I had trouble this weekend, but I tried again today with the same problem.


"Andrew Hendrickson" <[log in to unmask]> wrote:

Hmm, when I connected the Anyconnect client downloaded and installed a new client version.

Perhaps Network Services was updating the clients installs on the host at the time you tried to connect?


On Sep 27, 2010, at 6:16 PM, Rama Kocherlakota wrote:

Sorry, should have mentioned - it's a Win7 netbook.

Rama

On 9/27/2010 5:45 PM, Rama Kocherlakota wrote:
I have an ASUS netbook that I am trying to use to access
sslvpn.uvm.edu. If I go to the web site, it goes through its
usual sequence of authenticating, downloading, and launching,
but then, in the process of activating the VPN adapter, it gives
me the rather cryptic error message that "VPN has encountered an
error" and fails.

- I've tried using the browser-based Java version under Chrome
and the Active-X version under MSIE.
- I've tried with the standalone AnyConnect application
- I've tried turning off the Windows firewall, FWIW.

But nothing seems to help. I'm working on a secured Wi-Fi
network - and other machines on the same Wi-Fi network connect
reliably with no issues. Any thoughts?

Thanks,

Rama

---
Rama Kocherlakota