Hi Naima -

I have also been assisting a couple users with the same problem in Thunderbirs version 6 (can't create sub-folders like you used to in TB - older versions).

I've gotten it to work, but rather wary of this solution:

We were told in the past (Client Svcs. colleages) to be sure the first 2 check-boxes under the Advanced server settings were NOT checked
([1] Show only subscribed folders, and, [2] Server supports folders that contain sub-folders and messages), and this has worked for using folders/sub-folders up until now.

My co-worker and I tested by checking that 2nd box, and then I was able to create a new folder (to contain only folders), and then created a sub-folder within. I closed and re-launched TB and I could see both.  I then turned off that setting, closed and re-launched again, and then was NOT able to create another sub-folder (but this method works for now).

I am able to create a new folder with a sub-folder in Webmail and it shows up fine in TB. I use both TB and Webmail at home and have not had
issues with finding my stored messages.

Not sure if that's entirely helpful but you could try it.  I looked on Mozilla's site and did other searches, and I also contacted the Helpline last week but wasn't able to glean much else.  These are some tips the Helpline gave me:

1) Click the "View" tab, then click "Folders," and make sure that "All" is selected.
2) Reinstall Thunderbird. You can do this by uninstalling and then reinstalling following the directions at this website:
and clicking first on the instructions for uninstalling, then on the instructions for reinstalling. As the website says, you will not lose your data, as the data is stored in the profile folder stored at a separate location.   If you try both of these things and you are still not satisfied, you can try contacting Mozilla at their website.

Mary F. Parent 
Information Technical Asst. 
ETS Client Services 
284 East Ave. 
University of Vermont 
Burlington, VT 05405

On 9/7/2011 12:44 PM, Naima T. Dennis wrote:
[log in to unmask]" type="cite"> We've been experiencing some erratic behavior from Thuderbird when attempting to create subfolders.   We create a folder that holds "Folders Only" properly but when attempting to create the subfolders the "New Folder" option is not always available. You can create one new subfolder and then the "New Folder" option is not available for subsequent folder creation.   When restarting Thunderbird the option is available again but you can use it only once.  The only way to get it to work properly is to start Thunderbird in Safe Mode and have all Add Ons disabled. 

If you are clicking on the main account>New Folder>Create as a subfolder of:  you cannot select "choose this for the parent" for any subfolder.

This sounds crazy but I was able to reproduce this on another machine and have had reports of the same behavior from other parts of the office. 

Anyone have any insight?

Naima T. Dennis
Senior Assistant Registrar for Technology
The University of Vermont
360 Waterman Bldg.
[log in to unmask]


UVM is subject to the Vermont Public Records Act and communications to and from this email address, including

attachments, are subject to disclosure unless exempted under the Act or otherwise applicable law.