Hi Chris,

Check the setting for Y1.  This controls the maximum output.  Jumo factory setting is 100% - maybe it got changed to a lower setting along the way.  You can find the manual at:


(One warning is that Thermo or someone might have set Y1 lower so that it would maintain set point better without overshooting).


On Sep 30, 2013, at 3:43 PM, Christopher Maupin wrote:

Hi all, 

I'm having an issue with my Gasbench GC oven. Since I began working with this Gasbench, the oven temp will not rise above 74C. I have tried using both a different relay and a different heating element with no success. 

Other Gasbenches I have used will of course easily go much higher. 

I recorded the rate of temp rise, and from 40-60 degrees, it will rise at about a degree per minute. After that, the temp vs. time slowly plateaus and painfully crawls up to 74ish and stays put firmly. 

My place of real ignorance here is with the Jumo Itron 16 temp controller. Is it possible that it was programmed to prevent a high temp setting? Both the elements I tried give a resistance of ~224 ohms and both relays appear to work...

Any thoughts you all can offer would be much appreciated. 

Chris Maupin
Research Associate and Facilities Manager
Stable Isotope Geosciences Facility (SIGF)
Geography Department
Texas A&M University
405 Eller O&M Building 3147 TAMU
College Station, TX 77843 USA
Mobile: (512) 810-8437

Jason Curtis, Ph.D.
Stable Isotope Mass Spec Lab manager
Senior Associate-In Geochemistry
Department of Geological Sciences
241 Williamson Hall
University of Florida
Gainesville, FL 32611
[log in to unmask], office 352-392-2296
lab 352-392-3344, fax 352-392-9294