I would run "gpedit.msc" and then disable the updates from the intranet setting and see if that works. 

Looking at the technet, I believe this is the correct setting: 
In Group Policy Object Editor, expand Computer Configuration, expand Administrative Templates, expand Windows Components, and then click Windows Update.

Where it says "Specify Intranet Microsoft update service location.", switch it to disabled or not configured. 

-Scott 


On 30 oct 2015, at 13:19, Diantha Howard <[log in to unmask]> wrote:

I have a Latitude E6400 running Windows 7.  It is not joined to the campus domain, but I have plugged it into a UVM network port from time to time.
For the past few months, It hasn't been getting updates.
When I run Windows update - with the default "check for updates managed by your system administrator", it finds no updates.  When I change to "check online for updates from Microsoft Update", it searches for quite a while, then gets error "Windows could not search for new updates." Code 8007000E.  When I run the "Windows Update Troubleshooter", it claims that it fixes errors.  When I "try again" - same thing.

Any suggestions?

Thanks,
Diantha

--
Diantha Howard
Biomedical Informatics
Center for Clinical and Translational Science
Given Courtyard S351
University of Vermont
(802) 656-8287