Hi Mayara,

Have you tried a mass scan with SO2 on? Perhaps looking at your calibration or focus settings could help.

If the mass scan comes up with nothing, I would try a heat gun along the path length of SO2. My suspect would be the reference supply block.

From my experience, SO2 needs the most free flowing, simple path as possible. The regulator may be heated, but the SO2 will probably be going back to liquid at any other cool spots. It is not the type of gas that conforms well to being turned on/off via valves, such as in the conflo IV. Personally, I prefer to use my older, simpler interfaces like a Conflo III and I use a devoted supply line all the way to the open split for SO2. There was some talk about issues with SO2 and the conflo IV in the past year I think. I would suspect the reference gas supply block might be a bottle neck for SO2.

None of our SO2 supply is heated. The key for us was to add a purge valve with large diameter capillary going to vent. This allows us to let the SO2 flow at a higher rate from what is permitted via the reference capillary and it gets the SO2 moving. I picture the SO2 supply lines having bits of liquid and gas bubbles within after any lapse in service. We can go from having our SO2 off at the tank to full flow in about 30 minutes. And we can drain the SO2 line in about 30s if we ever want to service something.

Good luck,


Benjamin Harlow
Manager, Stable Isotope Core Laboratory
Washington State University
367 Eastlick | Pullman, WA  99164-4236
Office: 509-335-6161 | Lab: 509-335-6154 | Fax:509-335-3184<>

From: Stable Isotope Geochemistry [mailto:[log in to unmask]] On Behalf Of Mayara Matos
Sent: Friday, February 03, 2017 8:15 AM
To: [log in to unmask]
Subject: [ISOGEOCHEM] Help with SO2 problem

Dear colleagues,

I'm seeking for some help from the ones working with S analysis in EA-IRMS. My reference SO2 peaks started to gradually disappear over time until no signal was observed, which made me think the tank was getting empty. This assumption combined with the low vapor pressure in the SO2 tank (showing a pressure around zero) made us purchase a new tank...

After installing the new SO2 tank, Isodat shows readings of no more than 1 mV for m/z 64 and 3mV for m/z 66. Because of this, an error message always pops up saying: "running script returns a fatal error: peak center failed." I opened our Conflo IV and checked if there was an actual gas flow from the tank to the capillaries coming out of the heated SO2 regulator (Conflo IV) and everything seems okay. Also, when I run a sequence for CNS, everything works fine for C and N but the system cannot make a jump to SO2.

Does anyone have a suggestion on how I can fix this problem? I couldn't find this exact issue on the Isogeochem archives.

Any help is appreciated.

Thank you!

Mayara Matos

Mayara P. V. Matos
PhD Candidate
Graduate Teaching Assistant
Department of Biology
West Virginia University
221 Oglebay Hall/ 4224 Life Sciences Building
Morgantown, WV 26506