Print

Print


I've had a lot of trouble with home directories over the years in OD. I'd
say the problem lies there and not anything to do with the NAS itself. When
you say you set up home drives for users of the drive, is that in Server?
I've had logins fail because the user isn't set up to use the right file
sharing protocol under the users list in Server. I can't tell if that's
what you're describing or not. When I was trying to fix, I would go into
the users list and make sure that under the edit access to services (going
from memory here, might not be exact) it was set up for all the protocols I
wanted to use.

You didn't mention it, but just to cover all bases, on the client macs, did
you set up the connection to the OD server under users/groups > login
options > network account server?

All this said, my experience has been that Apple seems to want to phase out
mobile home directories altogether and their support for it has gotten
worse and worse over the years. Another option would be to allow users to
simply log in with local accounts and mount their own network share folder
(using the user login you create for them) from the server and just save
everything there.

Hopefully there's something of help here. Like I said, I'm going off of
memory on a lot of it.


On Wed, Oct 18, 2017 at 10:58 AM, Leslie, Ben <[log in to unmask]> wrote:

> I'm hoping some OSX server experts can help me out with this.  I'm trying
> to setup a small mac lab, with OSX server and about 10 mac clients. For now
> I don't want accounts integrated with our Windows AD so I setup OSX server
> with OD.  My main goal is to provide these clients with network storage so
> they can use any computer in the lab and still have access to their files.
>
>
> I purchased a small NAS drive, that supports AFP and SMB.  I've mounted
> the drive on the server and can read/write to it.  I've set this drive up
> under file sharing in SERVER, and can assign home drives for users to this
> drive....enabling the proper SMB/AFP check boxes.
>
> When I attempt to log in to the mac client, I get a very cryptic error
> "You are unable to login to the user (username) at this time. Logging in to
> the account failed because an error occurred."
>
> Googling this and looking at some mac console errors, it seems to be a
> possible permissions error...I see this error message "osx error
> authorizationhost homedirmounter returned 65"
>
> I've checked the permissions on the NAS folder within osx server and it's
> all set to R/W (for testing).  The NAS folder configured on the device's
> console has guest access enabled.
>
>
>
> What am I missing?
>
> Thanks
>
> Ben Leslie
> Battenkill Valley Supervisory Union
> P: 802-375-2589 ext. 144 <(802)%20375-2589>
> P: 802-375-6409 <(802)%20375-6409>
>
>
> -----------------------------------------------------------------------
>
> Search <http://list.uvm.edu/archives/school-it.html> the SCHOOL-IT Archive
>
> Manage <http://list.uvm.edu/cgi-bin/wa?SUBED1=SCHOOL-IT&A=1> your
> Subscription to SCHOOL-IT
>



-- 
Ms. Hadley Markoski
Network Administrator
[log in to unmask]