Wei Huan,

    Maybe one of your turbos locked up.  Could be possible a short somewhere.

John M Harris

Stable Isotope Lab Manager
Florida International University

From: Stable Isotope Geochemistry <[log in to unmask]> on behalf of Wei Huang <[log in to unmask]>
Sent: Tuesday, December 11, 2018 5:06 PM
To: [log in to unmask]
Subject: [ISOGEOCHEM] Turbo pump fuses failed
Dear all,

My lab has two Edwards Turbo pumps (EXT 750DX), which didn't spin when I started our Isoprime mass spec a few days ago. These two pumps connect to dual inlet and multi-prep respectively. I found the two fuses on the motherboard located next to the turbo pump power supplies were failed. I replaced the two fuses, and tried to start the turbo pumps. The same thing happened -  both fuses were blown again. However, they worked very well a couple weeks ago before I shut down the mass spec. 

I ordered more fuses, but they are on back order. What could be the problem? Fuses? motherboard? or the turbo pumps? Could it be possible to have both turbo pumps failed at the same time?

Does anybody have this problem before? Any suggestion? Thanks a lot!


Wei Huang, Ph.D.


Stable Isotope Lab Manager

Lamont-Doherty Earth Observatory of Columbia University

[log in to unmask]