Dear all,

We are experiencing some issues with one one of our Delta V Advantages. It all started with a 0.89kV HV reading after cleaning the source (filament was showing signs of being about to die). Have had similar symptoms before, the source was taken apart again, cleaned a second time, and after reinstalling, things looked perfectly fine: 3.05kV HV, nice vacuum, box, trap values where they should be, but no mass readout on the cups. 0 or -0 on all three cups, irrespective of the gas it's looking at. Mass scan gives low noise signal over the whole scan. Changed the filament to another one to be sure, checked all the wires, no shorts, and still no signal. Swapped the sources with an identical Delta V, still no signal , but the cleaned source in the other Delta works fine (at least there is a mass read out). So we excluded an issue with the source, and not sure where to look next.

At the back of the instrument, all LEDs are working (we've compared the 2 identical IRMS), no sign of any burned fuses. We saw a few earlier posts describing similar problems that were solved by changing certain capacitors on the magnet current regulator board, or on the ion source control board.

Any advice on where to look first or what to test to find our culprit would be very welcome.

Thanks in advance


Signature Department of Earth & Environmental Sciences
KU Leuven

GoogleScholar - Researchgate